SkinSharp简介

帮助文档
Help >
SkinSharp简介

SkinSharp是Windows环境下一款强大的通用换肤库。

SkinSharp作为通用换肤库，只需要在您的程序中添加一行代码，就能让您的界面焕然一新，并拥有多种主题风格和色调的动态切换功能以及Aero透明边框特效。

SkinSharp采用独特的软件界面开发技术，让原本复杂繁琐的界面编程变得轻松自如。SkinSharp换肤库目前支持所有流行的开发工具。SkinSharp可以在不修改客户程序的基础上，对在Windows上运行的任何程序进行随意换肤，完全实现了将程序界面与业务逻辑彻底分离，从而可以让您轻松地完成程序界面的完美升级。

SkinSharp优势
SkinSharp与同类产品相比有如下优势:

1. 超轻量级换肤，SkinSharp不依赖于任何第三方类库或模板库(STL，MFC，ATL等)，仅仅使用到系统最基本的核心动态链接库。因此体积在同类产品上是最小的，仅不到200K，运行效率也是最高的，所有绘制和操作全部都是基于Win32 API的， 其他同类换肤库则十分臃肿。

2. SkinSharp 在滚动条和菜单换肤上，和其他同类换肤库有着明显的优势。在滚动条换肤上，SkinSharp做到了所有控件内置滚动条的换肤，并且不修改控件任何风格和属性，完美兼容各个控件。在菜单换肤上，SkinSharp采用独特的技术对所有菜单实行换肤，没错，是所有的菜单，包括IE控件内部菜单，系统菜单，滚动条菜单等等，只要是菜单就能换肤！并且支持所有菜单的透明！

3. SkinSharp 采用先进的皮肤格式，完美兼容各种不同形状外观的皮肤制作。SkinSharp皮肤采用超高压缩率，体积超小，最小的皮肤小于10K。载入效率极高，无任何延迟！设计的先进性使得SkinSharp的皮肤有着很好的版本兼容性，即使今后增加了皮肤属性项，也依然能够保持版本的兼容性。 SkinSharp的皮肤同时支持加密功能，保护您自己设计的皮肤不被其他人恶意使用。

4. SkinSharp 可以让你轻松拥有Aero透明边框以及阴影特效！SkinSharp仅用标准的GDI API就实现了Aero特效，并且效率极高！ 其他换肤库则没有此特性或者使用了GDI+,这样在Windows 2000等系统中你就必须多带一个GDI+的动态链接库，并且效率会有所影响。另外，SkinSharp还支持边缘阴影，还可以调整阴影参数， 实现超炫效果！

5. SkinSharp 支持更改皮肤的色调，饱和度，亮度，窗体的透明度，菜单的透明度。仅一款皮肤，您就可以拥有不同的色调主题！做出类似QQ色调主题是一件轻而易举的事情！

6. SkinSharp 并非COM组件，仅以标准的动态或静态链接库的形式存在，SkinSharp无需进行系统注册，直接使用!

7. SkinSharp 完全支持Unicode，提供多种编码格式，支持静态库链接，与客户程序可以进行无缝整合！支持绝大多数第三方控件的完美换肤！界面与业务逻辑彻底分离！

更多优势特性等待您去发掘！

官网：https://www.skinsharp.com/htdocs/cn/

This file was created by the WINCHM. Theme design:Cristian Ng


SkinH_Attach

帮助文档
Help > 接口列表 >
SkinH_Attach

SkinH_Attach

声明:

VC | int SkinH_Attach()
VB | Public Declare Function SkinH_Attach Lib "SkinH_VB6.dll" () As Long
易语言
DLL命令名 | 返回值数据类型 | 公开 | 备注
SkinH_Attach | 整数型 | √ |
DLL库文件名
SkinH_EL.dll
在DLL库中对应命令名
SkinH_Attach
成员名 | 类型 | 传址 | 数组 | 备注

参数:

无

功能:

加载程序当前目录下的文件名skinh.she皮肤进行换肤

返回值:

成功返回0，失败返回非0 (错误代码)

示例:

Visual C++ [image] Visual Basic 6.0 [image] 易语言


SkinH_AttachEx

帮助文档
SkinH_AttachEx

SkinH_AttachEx

声明:

VC | int SkinH_AttachEx(LPCTSTR strSkin, LPCTSTR strPwd)
VB | Public Declare Function SkinH_AttachEx Lib "SkinH_VB6.dll" (ByVal strSkin As String, ByVal strPwd As String) As Long
易语言
DLL命令名 | 返回值数据类型 | 公开 | 备注
SkinH_AttachEx | 整数型 | √ |
DLL库文件名
SkinH_EL.dll
在DLL库中对应命令名
SkinH_AttachEx
成员名 | 类型 | 传址 | 数组 | 备注
皮肤路径 | 文本型 |  |  |
皮肤口令 | 文本型 |  |  |

参数:

strSkin | 皮肤文件路径
strPwd | 皮肤密钥

功能:

加载指定路径的皮肤进行换肤

返回值:

成功返回0，失败返回非0 (错误代码)

示例:


SkinH_AttachExt

帮助文档
SkinH_AttachExt

SkinH_AttachExt

声明:

VC | int SkinH_AttachExt(LPCTSTR strSkin, LPCTSTR strPwd, int nHue, int nSat, int nBri)
VB | Public Declare Function SkinH_AttachExt Lib "SkinH_VB6.dll" (ByVal strSkin As String, ByVal strPwd As String, ByVal nHue As Integer, ByVal nSat As Integer, ByVal nBri As Integer) As Long
易语言
DLL命令名 | 返回值数据类型 | 公开 | 备注
SkinH_AttachExt | 整数型 | √ |
DLL库文件名
SkinH_EL.dll
在DLL库中对应命令名
SkinH_AttachExt
成员名 | 类型 | 传址 | 数组 | 备注
皮肤路径 | 文本型 |  |  |
皮肤口令 | 文本型 |  |  |
色调 | 整数型 |  |  | 取值范围-180-180,默认值0
饱和度 | 整数型 |  |  | 取值范围-100-100,默认值0
亮度 | 整数型 |  |  | 取值范围-100-100,默认值0

参数:

strSkin | 皮肤文件路径
strPwd | 皮肤密钥
nHue | 色调，取值范围-180-180,默认值0
nSat | 饱和度，取值范围-100-100,默认值0
nBri | 亮度，取值范围-100-100,默认值0

功能:

加载指定路径的皮肤进行换肤并指定相应的色调，饱和度，亮度

返回值:

成功返回0，失败返回非0 (错误代码)

示例:


SkinH_AttachRes

帮助文档
SkinH_AttachRes

声明:

VC | int SkinH_AttachRes(BYTE* pShe, int nSize, LPCTSTR strPwd, int nHue, int nSat, int nBri)
VB | Public Declare Function SkinH_AttachRes Lib "SkinH_VB6.dll" (lpRes As Any, ByVal nSize As Long, ByVal lpPasswd As String, ByVal nHue As Integer, ByVal nSat As Integer, ByVal nBri As Integer) As Long
易语言
DLL命令名 | 返回值数据类型 | 公开 | 备注
SkinH_AttachRes | 整数型 | √ |
DLL库文件名
SkinH_EL.dll
在DLL库中对应命令名
SkinH_AttachRes
成员名 | 类型 | 传址 | 数组 | 备注
资源皮肤 | 字节集 |  |  |
资源大小 | 整数型 |  |  |
皮肤口令 | 文本型 |  |  |
色调 | 整数型 |  |  | 取值范围-180-180,默认值0
饱和度 | 整数型 |  |  | 取值范围-100-100,默认值0
亮度 | 整数型 |  |  | 取值范围-100-100,默认值0

参数:

pShe | 资源皮肤数据指针
nSize | 资源皮肤数据长度
strPwd | 皮肤密钥
nHue | 色调，取值范围-180-180,默认值0
nSat | 饱和度，取值范围-100-100,默认值0
nBri | 亮度，取值范围-100-100,默认值0

功能:

加载指定资源进行换肤并指定相应的色调，饱和度，亮度

返回值:

成功返回0，失败返回非0 (错误代码)

示例:


SkinH_Detach

帮助文档
SkinH_Detach

SkinH_Detach

声明:

VC | int SkinH_Detach()
VB | Public Declare Function SkinH_Detach Lib "SkinH_VB6.dll" () As Long
易语言
DLL命令名 | 返回值数据类型 | 公开 | 备注
SkinH_Detach | 整数型 | √ |
DLL库文件名
SkinH_EL.dll
在DLL库中对应命令名
SkinH_Detach
成员名 | 类型 | 传址 | 数组 | 备注

参数:

无

功能:

卸载换肤 (注意:在换肤或者程序退出时换肤库会自动卸载当前皮肤,无需再调用此接口进行卸载)

返回值:

成功返回0，失败返回非0 (错误代码)

示例:


SkinH_DetachEx

帮助文档
SkinH_DetachEx

SkinH_DetachEx

声明:

VC | int SkinH_DetachEx(HWND hWnd)
VB | Public Declare Function SkinH_DetachEx Lib "SkinH_VB6.dll" (ByVal hWnd As Long) As Long
易语言
DLL命令名 | 返回值数据类型 | 公开 | 备注
SkinH_DetachEx | 整数型 | √ |
DLL库文件名
SkinH_EL.dll
在DLL库中对应命令名
SkinH_DetachEx
成员名 | 类型 | 传址 | 数组 | 备注
句柄 | 整数型 |  |  |

参数:

hWnd 指定窗体或控件的句柄

功能:

卸载指定句柄的窗体或者控件的皮肤

返回值:

成功返回0，失败返回非0 (错误代码)

示例:


SkinH_SetWindowAlpha

帮助文档
SkinH_SetWindowAlpha

SkinH_SetWindowAlpha

声明:

VC | int SkinH_SetWindowAlpha(HWND hWnd,int nAlpha)
VB | Public Declare Function SkinH_SetWindowAlpha Lib "SkinH_VB6.dll" (ByVal hWnd As Long, ByVal nAlpha As Integer) As Long
易语言
DLL命令名 | 返回值数据类型 | 公开 | 备注
SkinH_SetWindowAlpha | 整数型 | √ |
DLL库文件名
SkinH_EL.dll
在DLL库中对应命令名
SkinH_SetWindowAlpha
成员名 | 类型 | 传址 | 数组 | 备注
句柄 | 整数型 |  |  |
透明度 | 整数型 |  |  |

参数:

hWnd | 指定窗体或控件的句柄
nAlpha | 透明度

功能:

设置指定句柄的窗体的透明度

返回值:

成功返回0，失败返回非0 (错误代码)

示例:


SkinH_GetColor

帮助文档
SkinH_GetColor

SkinH_GetColor

声明:

VC | COLORREF SkinH_GetColor(HWND hWnd, int nPosX, int nPosY)
VB | Public Declare Function SkinH_GetColor Lib "SkinH_VB6.dll" (ByVal hWnd As Long, ByVal nPosX As Integer, ByVal nPosY As Integer) As Long
易语言
DLL命令名 | 返回值数据类型 | 公开 | 备注
SkinH_GetColor | 整数型 | √ |
DLL库文件名
SkinH_EL.dll
在DLL库中对应命令名
SkinH_GetColor
成员名 | 类型 | 传址 | 数组 | 备注
句柄 | 整数型 |  |  |
横坐标 | 整数型 |  |  |
纵坐标 | 整数型 |  |  |

参数:

hWnd | 指定窗体或控件的句柄
nPosX | 横坐标
nPosY | 纵坐标

功能:

获取指定窗口或控件在nX,nY处的颜色值

返回值:

成功返回无符号整型的颜色值(RGB)，失败返回0 (错误代码)

示例:


SkinH_AdjustHSV

帮助文档
SkinH_AdjustHSV

SkinH_AdjustHSV

声明:

VC | int SkinH_AdjustHSV(int nHue, int nSat, int nBri)
VB | Public Declare Function SkinH_AdjustHSV Lib "SkinH_VB6.dll" (ByVal nHue As Integer, ByVal nSat As Integer, ByVal nBri As Integer) As Long
易语言
DLL命令名 | 返回值数据类型 | 公开 | 备注
SkinH_AdjustHSV | 整数型 | √ |
DLL库文件名
SkinH_EL.dll
在DLL库中对应命令名
SkinH_AdjustHSV
成员名 | 类型 | 传址 | 数组 | 备注
色调 | 整数型 |  |  | 取值范围-180-180,默认值0
饱和度 | 整数型 |  |  | 取值范围-100-100,默认值0
亮度 | 整数型 |  |  | 取值范围-100-100,默认值0

参数:

nHue | 色调，取值范围-180-180,默认值0
nSat | 饱和度，取值范围-100-100,默认值0
nBri | 亮度，取值范围-100-100,默认值0

功能:

调整当前皮肤的色调，饱和度，亮度

返回值:

成功返回0，失败返回非0 (错误代码)

示例:


SkinH_Map

帮助文档
SkinH_Map

SkinH_Map

声明:

VC | int SkinH_Map(HWND hWnd,int nType)
VB | Public Declare Function SkinH_Map Lib "SkinH_VB6.dll" (ByVal hWnd As Long, ByVal nType As Integer) As Long
易语言
DLL命令名 | 返回值数据类型 | 公开 | 备注
SkinH_Map | 整数型 | √ |
DLL库文件名
SkinH_EL.dll
在DLL库中对应命令名
SkinH_Map
成员名 | 类型 | 传址 | 数组 | 备注
句柄 | 整数型 |  |  |
换肤类型 | 整数型 |  |  |

参数:

hWnd 指定窗体或控件的句柄
nType 换肤类型，取值如下
类型 | 对应数值 | 注释
TYPE_UNKNOWN | 0 | 未知类型
TYPE_ANIMATE | 1001 | 动画控件
TYPE_CHECKBOX | 1002 | 复选框
TYPE_COMBOBOX | 1003 | 组合框
TYPE_COMBOLBOX | 1004 | 组合下拉框
TYPE_CONTROLBAR | 1005 | 控件栏
TYPE_DATETIME | 1006 | 日期控件
TYPE_EDITBOX | 1007 | 文本框
TYPE_GROUPBOX | 1008 | 分组框
TYPE_HEADERCTRL | 1009 | 列头控件
TYPE_HOTKEY | 1010 | 热键控件
TYPE_IPADDRESS | 1011 | IP地址控件
TYPE_LABEL | 1012 | 标签控件
TYPE_LISTBOX | 1013 | 列表框
TYPE_LISTVIEW | 1014 | 列表视图
TYPE_MDICLIENT | 1015 | MDI客户区
TYPE_MENU | 1016 | 菜单
TYPE_MONTHCAL | 1017 | 月历控件
TYPE_PICTURE | 1018 | 图片框
TYPE_PROGRESS | 1019 | 进度条
TYPE_PUSHBUTTON | 1020 | 普通按钮
TYPE_RADIOBUTTON | 1021 | 单选框
TYPE_REBAR | 1022 | 重组栏
TYPE_RICHEDIT | 1023 | 富文本框
TYPE_SCROLLBAR | 1024 | 滚动条
TYPE_SCROLLCTRL | 1025 | 内置滚动条的控件
TYPE_SPINCTRL | 1026 | 调节器
TYPE_STATUSBAR | 1027 | 状态栏
TYPE_TABCTRL | 1028 | 选择夹
TYPE_TOOLBAR | 1029 | 工具栏
TYPE_TOOLBARWND | 1030 | MFC工具栏窗体
TYPE_TRACKBAR | 1031 | 滑条控件
TYPE_TREEVIEW | 1032 | 树形视图
TYPE_WINDOW | 1034 | 标准窗体
TYPE_COMCTRL | 1036 | 通用换肤1
TYPE_PAINTCTRL | 1037 | 通用换肤2
TYPE_DNET_LABEL | 2001 | 标签(.Net)
TYPE_DNET_WINDOW | 2002 | 窗体(.Net)
TYPE_DNET_CHECKBOX | 2003 | 复选框(.Net)
TYPE_DNET_RADIOBUTTON | 2004 | 单选框(.Net)
TYPE_DNET_PUSHBUTTON | 2005 | 普通按钮(.Net)
TYPE_DNET_TOOLSTRIP | 2006 | 工具栏(.Net)
TYPE_DNET_MENUSTRIP | 2007 | 菜单栏(.Net)
TYPE_DNET_STATUSSTRIP | 2008 | 状态栏(.Net)
TYPE_DNET_TOOLSTRIPMENU | 2009 | 工具菜单(.Net)
TYPE_DNET_TOOLSTRIPOVERFLOW | 2010 | 工具溢出菜单(.Net)
TYPE_DNET_DATAGRIDVIEW | 2011 | 数据视图(.Net)
TYPE_DELPHI_WINDOW | 3001 | 窗体(Delphi)
TYPE_DELPHI_BITBUTTON | 3002 | 位图按钮(Delphi)
TYPE_DELPHI_TWINCONTROL | 3003 |
TYPE_DELPHI_GROUPBOX | 3004 | 分组框(Delphi)
TYPE_VB_FORM | 4001 | 窗体(VB6)
TYPE_VB_PUSHBUTTON | 4002 | 普通按钮(VB6)
TYPE_VB_RADIOBUTTON | 4003 | 单选框(VB6)
TYPE_VB_CHECKBOX | 4004 | 复选框(VB6)
TYPE_VB_GROUPBOX | 4005 | 分组框(VB6)
TYPE_VB_TABCTRL | 4006 | 选择夹(VB6)
TYPE_VB_DATACOMBOCTRL | 4007 | 数据组合框(VB6)
TYPE_EL_EDIT | 5001 | 文本框(易语言)
TYPE_EL_WINDOW | 5002 | 窗体(易语言)
TYPE_EL_COLORSEL | 5003 | 颜色选择器(易语言)
TYPE_PB_FORM | 6001 | 窗体(PB)
TYPE_PB_PICTUREBUTTON | 6002 | 图片框(PB)
TYPE_PB_TABCTRL | 6003 | 选择夹(PB)

功能:

指定窗体和控件的换肤类型

返回值:

成功返回0，失败返回非0 (错误代码)

示例:


SkinH_LockUpdate

帮助文档
SkinH_LockUpdate

SkinH_LockUpdate

声明:

VC | int SkinH_LockUpdate(HWND hWnd,int nLocked)
VB | Public Declare Function SkinH_LockUpdate Lib "SkinH_VB6.dll" (ByVal hWnd As Long, ByVal nLocked As Integer) As Long
易语言
DLL命令名 | 返回值数据类型 | 公开 | 备注
SkinH_LockUpdate | 整数型 | √ |
DLL库文件名
SkinH_EL.dll
在DLL库中对应命令名
SkinH_LockUpdate
成员名 | 类型 | 传址 | 数组 | 备注
句柄 | 整数型 |  |  |
锁定 | 整数型 |  |  |

参数:

hWnd | 指定窗体或控件的句柄
nLocked | 是否锁定。1为锁定，0为解锁

功能:

用于填充表格或者列表控件数据时，重复绘制滚动条影响执行效率问题

返回值:

成功返回0，失败返回非0 (错误代码)

示例:


SkinH_SetAero

帮助文档
SkinH_SetAero

SkinH_SetAero

声明:

VC | int SkinH_SetAero(HWND hWnd)
VB | Public Declare Function SkinH_SetAero Lib "SkinH_VB6.dll" (ByVal hWnd As Long) As Long
易语言
DLL命令名 | 返回值数据类型 | 公开 | 备注
SkinH_SetAero | 整数型 | √ |
DLL库文件名
SkinH_EL.dll
在DLL库中对应命令名
SkinH_SetAero
成员名 | 类型 | 传址 | 数组 | 备注
有效位 | 整数型 |  |  |

参数:

bAero Vista特效是否有效,1为开启特效,0为关闭特效

功能:

设置Vista特效

返回值:

成功返回0，失败返回非0 (错误代码)

示例:


SkinH_SetBackColor

帮助文档
SkinH_SetBackColor

SkinH_SetBackColor

声明:

VC | int SkinH_SetBackColor(HWND hWnd, int nRed, int nGreen, int nBlue)
VB | Public Declare Function SkinH_SetBackColor Lib "SkinH_VB6.dll" (ByVal hWnd As Long, ByVal nRed As Integer, ByVal nGreen As Integer, ByVal nBlue As Integer) As Long
易语言
DLL命令名 | 返回值数据类型 | 公开 | 备注
SkinH_SetBackColor | 整数型 | √ |
DLL库文件名
SkinH_EL.dll
在DLL库中对应命令名
SkinH_SetBackColor
成员名 | 类型 | 传址 | 数组 | 备注
句柄 | 整数型 |  |  |
红色分量 | 整数型 |  |  | 取值范围0-255
绿色分量 | 整数型 |  |  | 取值范围0-255
蓝色分量 | 整数型 |  |  | 取值范围0-255

参数:

hWnd | 控件句柄
nRed | 红色分量
nGreen | 绿色分量
nBlue | 蓝色分量

功能:

设置控件的背景色(目前仅对单选框,复选框,分组框有效)

返回值:

成功返回0，失败返回非0 (错误代码)

示例:


SkinH_SetForeColor

帮助文档
SkinH_SetForeColor

SkinH_SetForeColor

声明:

VC | int SkinH_SetForeColor(HWND hWnd, int nRed, int nGreen, int nBlue)
VB | Public Declare Function SkinH_SetForeColor Lib "SkinH_VB6.dll" (ByVal hWnd As Long, ByVal nRed As Integer, ByVal nGreen As Integer, ByVal nBlue As Integer) As Long
易语言
DLL命令名 | 返回值数据类型 | 公开 | 备注
SkinH_SetForeColor | 整数型 | √ |
DLL库文件名
SkinH_EL.dll
在DLL库中对应命令名
SkinH_SetForeColor
成员名 | 类型 | 传址 | 数组 | 备注
句柄 | 整数型 |  |  |
红色分量 | 整数型 |  |  | 取值范围0-255
绿色分量 | 整数型 |  |  | 取值范围0-255
蓝色分量 | 整数型 |  |  | 取值范围0-255

参数:

hWnd | 控件句柄
nRed | 红色分量
nGreen | 绿色分量
nBlue | 蓝色分量

功能:

设置控件的文本颜色色(目前仅对单选框,复选框,分组框有效)

返回值:

成功返回0，失败返回非0 (错误代码)

示例:


SkinH_SetWindowMovable

帮助文档
SkinH_SetWindowMovable

SkinH_SetWindowMovable

声明:

VC | int SkinH_SetWindowMovable(HWND hWnd,BOOL bMove)
VB | Public Declare Function SkinH_SetWindowMovable Lib "SkinH_VB6.dll" (ByVal hWnd As Long, ByVal bMove As Integer) As Long
易语言
DLL命令名 | 返回值数据类型 | 公开 | 备注
SkinH_SetWindowMovable | 整数型 | √ |
DLL库文件名
SkinH_EL.dll
在DLL库中对应命令名
SkinH_SetWindowMovable
成员名 | 类型 | 传址 | 数组 | 备注
句柄 | 整数型 |  |  | 窗口句柄
是否可移动 | 整数型 |  |  | 0为不可移动,1为可移动

参数:

hWnd | 窗口句柄
bMove | 0为不可移动,1为可移动

功能:

设置窗体是否可以移动

返回值:

成功返回0，失败返回非0 (错误代码)

示例:


SkinH_AdjustAero

帮助文档
SkinH_AdjustAero

SkinH_AdjustAero

声明:

VC | int SkinH_AdjustAero(int nAlpha, int nShwDark, int nShwSharp,int nShwSize,int nX,int nY,int nRed,int nGreen,int nBlue)
VB | Public Declare Function SkinH_AdjustAero Lib "SkinH_VB6.dll" (ByVal nAlpha As Integer, ByVal nShwDark As Integer, ByVal nShwSharp As Integer,ByVal nShwSize As Integer,ByVal nX As Integer,ByVal nY As Integer,ByVal nRed As Integer,ByVal nGreen As Integer,ByVal nBlue As Integer) As Long
易语言
DLL命令名 | 返回值数据类型 | 公开 | 备注
SkinH_AdjustAero | 整数型 | √ |
DLL库文件名
SkinH_EL.dll
在DLL库中对应命令名
SkinH_AdjustAero
成员名 | 类型 | 传址 | 数组 | 备注
透明度 | 整数型 |  |  | 0－255, 默认值0
亮度 | 整数型 |  |  | 0－255, 默认值0
锐度 | 整数型 |  |  | 0－12, 默认值0
阴影大小 | 整数型 |  |  | 0－18, 默认值0
水平偏移 | 整数型 |  |  | 默认值0
垂直偏移 | 整数型 |  |  | 默认值0
红色分量 | 整数型 |  |  | 0－255, 默认值0
绿色分量 | 整数型 |  |  | 0－255, 默认值0
蓝色分量 | 整数型 |  |  | 0－255, 默认值0

参数:

nAlpha | 透明度, 0-255, 默认值0
nShwDark | 亮度, 0-255, 默认值0
nShwSharp | 锐度, 0-12, 默认值0
nShwSize | 阴影大小, 0-18, 默认值0
nX | 水平偏移, 0-25, 默认值0
nY | 垂直偏移, 0-25, 默认值0
nRed | 红色分量, 0-255, 默认值0
nGreen | 绿色分量, 0-255, 默认值0
nBlue | 蓝色分量, 0-255, 默认值0

功能:

设置透明窗体参数

返回值:

成功返回0，失败返回非0 (错误代码)

示例:


SkinH_NineBlt

帮助文档
SkinH_NineBlt

SkinH_NineBlt

声明:

VC | int SkinH_NineBlt(HDC hDtDC,int left,int top,int right, int bottom, int nMRect)
VB | Public Declare Function SkinH_NineBlt Lib "SkinH_VB6.dll" (ByVal hDtDC As Long, ByVal left As Integer, ByVal top As Integer, ByVal right As Integer, ByVal bottom As Integer, ByVal nMRect As Integer) As Long
易语言
DLL命令名 | 返回值数据类型 | 公开 | 备注
SkinH_NineBlt | 整数型 | √ |
DLL库文件名
SkinH_EL.dll
在DLL库中对应命令名
SkinH_NineBlt
成员名 | 类型 | 传址 | 数组 | 备注
hDC | 整数型 |  |  |
left | 整数型 |  |  |
top | 整数型 |  |  |
right | 整数型 |  |  |
bottom | 整数型 |  |  |
nMRect | 整数型 |  |  |

参数:

hDtDC | 目标设备上下文
left | 左上角水平坐标
top | 左上角垂直坐标
right | 右下角水平坐标
bottom | 右下角垂直坐标
nMRect | 元素id

功能:

绘制指定设备上下文的元素

返回值:

成功返回0，失败返回非0 (错误代码)

示例:


SkinH_VerifySign

帮助文档
SkinH_VerifySign

SkinH_VerifySign

声明:

VC | int SkinH_VerifySign()
VB | Public Declare Function SkinH_VerifySign Lib "SkinH_VB6.dll" () As Long
易语言
DLL命令名 | 返回值数据类型 | 公开 | 备注
SkinH_VerifySign | 整数型 | √ |
DLL库文件名
SkinH_EL.dll
在DLL库中对应命令名
SkinH_VerifySign
成员名 | 类型 | 传址 | 数组 | 备注

参数:

无

功能:

返回签名结果

返回值:

已签名返回1，未签名返回0

示例:


SkinH_Auth

帮助文档
SkinH_Auth

SkinH_Auth

声明:

VC | int SkinH_Auth(LPCSTR szAuthCode)
VB | Public Declare Function SkinH_Auth Lib "SkinH_VB6.dll" (ByVal strAuthCode As String) As Long

参数:

szAuthCode 授权码

功能:

正版授权

返回值:

成功返回0，失败返回非0 (错误代码)


错误代码

帮助文档
错误代码

错误代码

SRET_OK | 0 | 操作成功
SRET_ERROR | 1 | 操作失败
SRET_ERROR_READ | 2 | 皮肤文件读取失败
SRET_ERROR_PARAM | 3 | 参数错误
SRET_ERROR_CREATE | 4 | 创建皮肤失败
SRET_ERROR_FORMAT | 5 | 皮肤格式错误
SRET_ERROR_VERSION | 6 | 皮肤版本错误
SRET_ERROR_PASSWORD | 7 | 皮肤密码错误
SRET_ERROR_INVALID | 8 | 皮肤引擎错误


易语言

帮助文档
Help > 常见问题 >
易语言
为什么无边框窗体换肤菜单栏不能操作了

您需要用SkinH_Map接口手动指定无边框窗体换肤。

修改窗口类名后无法换肤的问题

换肤库是根据窗口类名来识别控件类别的，修改窗口类可能导致换肤不正常或者无法换肤，所以建议一般情况不要修改窗口类。如确实需要修改，可以用SkinH_Map接口指定相应控件或窗体的换肤类型。

程序加壳后运行不了

若程序需要加壳，请在加壳后进行换肤库数字签名(加密)


Visual Basic

帮助文档
Help > 常见问题 >
Visual Basic
调试运行时出现非法操作错误,并导致VB环境退出的问题

首先这种情况只会在调试运行时出现，编译后是不会出现此问题的

其次这种情况大部分是由于用户使用了End语句结束程序导致的。先来看看End语句和Unload等语句的区别

1.Unload 语句

从内存中卸载窗体或控件. 在卸载窗体前,会发生 Query_Unload 事件过程,然后是 Form_Unload 事件过程。在其中任一过程中设置 cancel 参数为 True 可防止窗体被卸载。

若为 MDIForm 对象，先发生 MDIForm 对象的 Query_Unload 事件过程，接着是各 MDI 子窗体 的 Query_Unload 事件过程和 Form_Unload 事件过程，最后是 MDIForm 对象的 Form_Unload 事件过程。例如，在窗体中关闭自己：unload Me。

2.End 语句

结束一个过程或块。

End 语句不调用 Unload、QueryUnload、或 Terminate 事件或任何其它 Visual Basic 代码，只是生硬地终止代码执行。窗体和类模块中的 Unload、QueryUnload、和 Terminate 事件代码未被执行。类模块创建的对象被破坏，由 Open 语句打开的文件被关闭，并且释放程序所占用的内存。其它程序的对象引用无效。

End 语句提供了一种强迫中止程序的方法。Visual Basic 程序正常结束应该卸载所有的窗体。只要没有其它程序引用该程序公共类模块创建的对象并无代码执行，程序将立即关闭。

3.hide

隐藏窗体或控件而已，并不从内存中卸载。

正是由于End语句只是生硬的终止执行,加上VB的调试时是单进程的，导致资源无法正确释放，进而导致非法操作！因此建议用户不要使用End语句来结束程序，而是使用Unload来卸载。当然，最好的方法是在调试阶段不使用换肤库。待程序完善后，最后加载换肤库。


Visual C++

帮助文档
Help > 常见问题 >
Visual C++
暂无

暂无